logo

Systemvoraussetzungen

Voraussetzungen für Process Modeler 6

Betriebssystem: XP Home/Professional, Vista, Windows 7, Windows 8

Frameworks: Microsoft .Net Framework 4.0 oder höher und Visual Studio 2010 Tools for Office Runtime VSTO  (beide werden während dem Setup heruntergeladen und installiert)

Microsoft Visio: Microsoft Visio™ 2007/2010/2013

Microsoft Office: Microsoft Word™ 2000/XP/2003/2007/2010/2013 (für einige Funktionen empfohlen)
Microsoft Excel™ 2000/XP/2003/2007/2010/2013 (für einige Funktionen empfohlen)
Microsoft PowerPoint™ 2000/XP/2003/2007/2010/2013 (für einige Funktionen empfohlen)
Microsoft Project™ 2000/XP/2003/2007/2010/2013 (für einige Funktionen empfohlen)

Browser: Microsoft Internet Explorer 5.01 oder höher (für die Installation von des .NET Framework notwendig)
Microsoft Silverlight™ (notwendig für den Visio™ 2010/2013 HTML-Export)

Wichtig: Die Installation der Frameworks benötigt Administratorberechtigungen.
Bitte vergewissern Sie sich, dass die letzten Service Packs und Updates für Ihr Betriebssystem installiert sind.

Systemvoraussetzungen für das Team Repository

Um das Team Repository evaluieren zu können, benötigen Sie eine lauffähige Datenbank-Instanz (MS-SQL Server ab 2012, ORACLE ab 9i, MySQL ab V5), auf welche Sie lokal oder remote zugreifen können.

Zur Installation der notwendigen Datenbank-Definitionen benötigen Sie Datenbank-Administrationsrechte (DBA) für die zu verwendende Datenbank-Instanz.
Die können das DB-Schema (Tabellen) und die benötigten Benutzer, Rollen und Berechtigungen mit dem Installations-Wizard erstellen oder Sie führen eine sogenannte “SQL-Script Installation” aus.

Das Installationshandbuch (Englisch) für das Team Repository finden Sie hier.

Das Team Repository Administrationsprogramm benötigt den ORACLE Instant Client for Microsoft Windows (x64) falls es mit ORACLE 11g unter Windows 7 64-Bit benutzt wird.

Wichtig: Installieren Sie den im Process Modeler-Installationspacket enthaltenen “Oracle Client – 32bit” NICHT!

Voraussetzungen für Process Modeler 5 und 6

Betriebssystem: Microsoft Windows 2000™, XP Home/Professional, Vista, Windows 7, Windows 8
inkl. Microsoft .Net Framework 2.0 oder höher
Wichtig: Visio™ 2010 benötigt .Net Framework 4.0 und Visual Studio 2010 Tools for Office Runtime (beide werden während dem Setup heruntergeladen und installiert)

Microsoft Visio: Microsoft Visio™ 2003/2007/2010 (32-bit),  Microsoft Visio™ 2010 (64-bit)
Achtung: Visio 2013 kann den PM5 (32-bit) nicht laden.

Microsoft Office: Microsoft Word™ 2000/XP/2003/2007/2010 (für verschiedene Funktionen empfohlen)
Microsoft Excel™ 2000/XP/2003/2007/2010 (für verschiedene Funktionen empfohlen)
Microsoft PowerPoint™ 2000/XP/2003/2007/2010 (für verschiedene Funktionen empfohlen)
Microsoft Project™ 2000/XP/2003/2007/2010 (für verschiedene Funktionen empfohlen)

Browser: Microsoft Internet Explorer 5.01 or higher (für die Installation des .NET Framework benötigt)
Microsoft Silverlight™ (benötigt für den Visio™ 2010 HTML-Export)

Wichtig: Die Installation für Systembibliotheken (.Net, VSTO) benötigt Administratorberechtigungen.
Bitte vergewissern Sie sich, dass die letzten Service Packs und Updates für Ihr Betriebssystem installiert sind.

Process Modeler 6 benötigt KEINE Administrator-Rechte, wenn für den eigenen Benutzer installiert wird.

Das Team Repository Administrationsprogramm benötigt den ORACLE Instant Client for Microsoft Windows (x64) falls es mit ORACLE 11g unter Windows 7 64-Bit benutzt wird.
Wichtig: Installieren Sie den im Process Modeler-Installationspacket enthaltenen “Oracle Client – 32bit” NICHT!